Virtualisierung

ID #1350 VMware: AltGr funktioniert in der Console nicht mehr

Problem:

In einer VMware wird ein minimales Linux-Gast-System (also ohne X-Window) installiert. Wenn diese VM startet und sich einloggt funktioniert evtl. die Alt-Gr-Taste nicht mehr. Diagnose: die Zeichen ~ (Tilde), \ (Backslash), | (Pipe) oder die [] (eckige) und {} (geschwungene Klammer) lassen sich nicht eingeben.

Lösung:

Im Internet findet man vor allem zwei Lösungen. Bei mir hat es erst Funktioniert, sobald ich beide erfüllt hatte:

a) Auf dem Hostsystem folgende Zeile in der Datei /etc/vmware/config ergänzen (oder File anlegen):

xkeymap.usekeycodeMap = true

b) Die o.g. Zeile in der Datei ~/.vmware/config ergänzen (oder File anlegen).

 

sozial Bookmarking
Bookmarken bei YIGG Bookmarken bei Mister-Wong Bookmarken bei Icio Bookmarken bei del.icio.us Bookmarken bei Technorati Bookmarken bei Furl Bookmarken bei Spurl Bookmarken bei Yahoo Bookmarken bei Google

huschi, zuletzt 2009-01-22 14:19     Artikel ausdrucken Artikel weiterempfehlen Als PDF-Datei anzeigen

Dieser Inhalt ist unter der Creative-Commons Lizenz lizensiert.

Probleme bitte im Server-Support-Forum diskutieren.

überflüssig 1 2 3 4 5 wertvoll  
Durchschnittliche Bewertung:   5 von 5 (2 Bewertungen)

Artikel kommentieren

Kommentar von Claudio (2009-03-24 12:31:57):
Besten Dank für die Info, hat mir soeben sehr geholfen.
kurze Ergänzung: Der ESX-Host muss leider einmal gebootet werden, um die Änderungen zu aktivieren.

Beste Grüße, Claudio

Kommentar von Jan (2009-08-10 12:39:31):
Vielen Dank für den Tip! Da ich VMware Infrastructure Web Access nutze, reichte ein erneutes einloggen aus.

Kommentar von Jörg (2012-09-25 11:42:16):
Shift und 2 ergen auch das @ Zeichen